Elevated HTTP Error rate for SDK-facing web services
Incident Report for OneSignal
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 19:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2024 - 19:25 UTC
Update
HTTP traffic has been re-enabled globally
Posted Jan 04, 2024 - 19:20 UTC
Update
As a part of the resolution, we blocked HTTP traffic from several geos and will be re-enabling in the next few minutes
Posted Jan 04, 2024 - 19:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 04, 2024 - 19:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 04, 2024 - 18:56 UTC
Investigating
The HTTP services which communicate with OneSignal SDKs is experiencing issues that are causing increased HTTP errors. This will prevent some SDK-based delivery metrics (confirmed deliveries, custom outcomes, etc) from correctly updating. IAMs may not display.

Notification/Email/SMS delivery should not be impacted by this issue.
Posted Jan 04, 2024 - 18:51 UTC
This incident affected: Dashboard and API and Analytics & Update Processing.