Dashboard login failures and logouts

Incident Report for OneSignal

Resolved

This incident has been resolved.
Posted Jan 14, 2025 - 00:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2025 - 23:50 UTC

Update

We believe the root cause has been identified as a misconfiguration of our database responsible for storing user sessions, causing replication lag resulting in user authentication being inconsistently validated by our dashboard API. We are resolving the issue now by adjusting how we read stored user sessions for our dashboard API and fixing the misconfiguration of our database for continued high performance of our database.
Posted Jan 13, 2025 - 23:32 UTC

Update

The reset password page is also affected.
Posted Jan 13, 2025 - 22:50 UTC

Identified

We've identified that the issue may be due to our reCAPTCHA integration for our login page. We have changed a feature flag and have confirmed the ability to log in using the "Stay logged in" checkbox.
Posted Jan 13, 2025 - 22:44 UTC

Investigating

We are doing root cause analysis to identify why customers are unable to login unless "Stay logged in" is checked during login. Some customers have reported not being able to login to dashboard at all.
Posted Jan 13, 2025 - 22:05 UTC
This incident affected: Dashboard and API.