High Latency on Live Activities
Resolved·Degraded performance

Latency has continued to be stable on Live Activities

Wed, May 21, 2025, 07:08 PM
(3 weeks ago)
·
Affected components
Delivery
Updates

Resolved

Latency has continued to be stable on Live Activities

Wed, May 21, 2025, 07:08 PM

Monitoring

Latency has subsided and we are continuing to monitor

Wed, May 21, 2025, 06:42 PM(25 minutes earlier)

Investigating

We're experiencing higher latency on Live Activities

Wed, May 21, 2025, 06:18 PM(24 minutes earlier)