No components marked as affected
Resolved
The issue has been resolved
Identified
The issue has been identified and we are resolving
Investigating
We are currently experiencing an issue that is degrading API performance and impacting Dashboard page loads for a number of our customers. Our team is actively working to resolve this problem and ensure full functionality is restored as soon as possible.