Resolved
The issue has been resolved. All impacted systems are now operating normally as of Monday 11:00 AM PDT.
Identified
We have identified the root cause and are adding additional resources to better handle the load. Currently affected components are Journeys, Event Streams, and Outbound Data Integrations.