Resolved
The necessary mitigations have been applied and all systems are now operating normally.
Identified
We've identified the root cause and are actively implementing mitigations.
Investigating
What’s happening: Timezone based and intelligent deliveries impacted because of backlog of messages.
Who’s affected:
Any free customers using Timezone-based Delivery, Intelligent Delivery, or Retry Delivery.
Current Status: We are investigating the issue and will provide an update in 30 minutes